Support

  1. PGITIWebsite
  2. Support
  3. Monday, February 25 2019, 12:28 AM
  4.  Subscribe via email
Hello,

Once a new user has verified their email address, an email is sent to the administrators. In this email there is a link to activate the new user however the link generates an error (We have not made any changes to the email provided by easy profile).
eg. "You can activate the user by selecting on the link below:

http://www.pgiti.com/registration-form.html?task=registration.activate&;token=96661154fcb4ab9525097464705cb265"

The message is Error: Please login to access this content.
However I am logged in. I am not sure how to fix this.

Thanks for any ideas, Alexandra
Accepted Answer
admin Accepted Answer
Admin
Hi,
fixed, this seems a Joomla issue.

When a user register own account the menu item "registration-form" is available (the access was "Guest";), so Joomla create a activation link based on this menu item. Unfortunately to activate user the admin need to be logged in but the link generated refer to a link not available ("Guest" access level is not available for Admins).

Now I have changed the menu item access from "Guest" to "Public" and the link works.

Why it is a Joomla issue?
Because a registration menu item should have access set to "Guest", no make a sense that this menu item is available for already registered users. So the link should be generated without any menu item with a link like
http://www.pgiti.com/index.php?option=com_users&task=registration.activate&token=96661154fcb4ab9525097464705cb265


With this you will see a error message in Component->Easy Profile, you can just ignore it. In your case this is not really important because you already have another menu item that refer to Joomla com_users component (it is "Edit Your Profile" )
admin Accepted Answer
Admin
Hi,
this is a Joomla behavior, you can activate user from a link only if you are logged in as Administrator. So after login you need to click to the link into email
  1. 3 weeks ago
  2. Support
  3. # 1
PGITIWebsite Accepted Answer
Pro
Hi, yes I login, go back to email and get this error.

Step 1- receive email
Step 2- if I try the link I get message: Log in to confirm that you are authorised to activate new accounts.
Step 3- Login
Step 4- go back to email and click on link

Error: Please login to access this content.

However I am logged in and can register etc.

I think the link maybe wrong?
Thanks
  1. 3 weeks ago
  2. Support
  3. # 2
admin Accepted Answer
Admin
Hi,
can you please post me your site details to check this behavior? if yes then you can use the form below the reply in "Site Details" tab
  1. 3 weeks ago
  2. Support
  3. # 3
PGITIWebsite Accepted Answer
Pro
Login info attached, let me know if you need more help. My phone number is 513-580-2320
Thanks
  1. 3 weeks ago
  2. Support
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy ProfileĀ® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.