Support

  1. anderslolk
  2. Support
  3. Thursday, September 26 2019, 08:41 AM
  4.  Subscribe via email
Hi.

I've some problems with conditions.

I've a checkbox (with one field) and when the checkbox is checked, some other text fields will show. It works fine, and the fields showes. But when I click Submit, the fields are hidden again. The data in the fields are saved, but fields are hidden.

Can you help me?
Attachments (2)
admin Accepted Answer
Admin
Hi,
the problem is not due to conditions, the field visible in the profile page is "sted_postnr" and not field "afgift_postnr" (hidden by condition).

Why you see only this field? Because in Easy Profile options the parameter called "Hide Empty Fields on Profile" is hidden but unfortunately "sted_postnr" contain the value 0.

Solution
To avoid this you can recreate the field "sted_postnr" with type "Text" instead "Number", you can also use "Format Allowed" parameter to allow only Zip codes for text field type (see screenshot)
Attachments (1)
  1. more than a month ago
  2. Support
  3. # 1
anderslolk Accepted Answer
Pro
Hi again.

I think I didn't explained the problem correct.

The problem is the fields under the headline Årsafgift in the Fakturering tab. The fields must be showed, when the field Ja is marked in the checkbox with the alias [afgift_ikke_lig_blinde_alarmer/i]. The fields are showing when editing profile, but not in show profile.

If I mark the [i]Ja
field in the checkbox when editing a profile, the fields are showing. When I click submit, the field is unmarked again, and the field don't show.
Attachments (3)
  1. more than a month ago
  2. Support
  3. # 2
admin Accepted Answer
Admin
Hi,
now it works, I have changed options from "Ja" to "1|Ja" (1 is the value and Ja is the text)
  1. more than a month ago
  2. Support
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy Profile® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.